Known Issues and Workarounds

Legacy Forum Archive Forums Doc-To-Help Doc-To-Help Known Issues and Workarounds

This topic contains 35 replies, has 13 voices, and was last updated by  S.Kamprowski 5 years ago.

Viewing 15 posts - 16 through 30 (of 36 total)
  • Author
    Posts
  • #208641

    TohtoriHelp
    Member

    I think I found the problem – it isn’t a Doc-To-Help problem, it’s a Word problem. The project I used to test D2H2012 had used the wrong template, so my guess is that the Manual output has never worked for this particular project. I will have to test it with a project that has the Word document in the correct format. In the case of this project, they only need the HTML output, so it looks like D2H2012 works just fine in this case.

    #208642

    TohtoriHelp
    Member

    Thanks again! I just read your previous reply after posting my last message 2 minutes ago.

    #208643

    TohtoriHelp
    Member

    Got everything working now :) Thanks for your help. I’ll go and buy some D2H 2012 licenses now.

    #208644

    Brad Keller
    Member
    2p

    Excellent! Glad you got everything working.

    #208645

    Claude
    Member

    Hello,
    I am running Doc-to-Help 2010.2.0.553 on Windows 7 Enterprise

    SP1 (64-bit). I am an Administrator for the workstation.

    When trying to produce a NetHelp project, Doc-to-Help stops at 37% and issues a “FATAL ERROR OCCURED: ABORT” message:

    Reading project data…
    Guide.doc
    Processing fields…
    Processing list paragraphs…
    Converting lists to text…
    Converting image map pictures…
    Saving preprocessed document…
    Preparing HTML file…
    Processing HTML file…
    ** Fatal error occurred: Abort.
    ** Build Failed.
    1 Error(s)
    0 Warning(s)
    0 Broken Link(s)

    Is this a known issue, is there a fix?
    Any idea what I can tweak or where I can do to solve this issue?

    Thanks,
    Claude

    #208646

    Brad Keller
    Member
    2p

    Claude,

    The most likely cause of this issue is that you have Internet Explorer 9 installed and that version doesn’t support IE 9. I would recommend either upgrading to 2011 V1 (Build 627) or uninstalling IE 9 and installing IE 8.

    Here’s the download link for that version:

    http://download.componentone.com/pub/HelpAuthoring/doctohelp2005/Updates/DocToHelp2011-1-Build627-Setup.exe

    If you’re not sure if you have access to this version, send an e-mail to bradk@componentone.com with your serial number and I’ll confirm whether or not you have access to 2011 V1.

    Hope this helps!
    Brad

    #208647

    Brad Keller
    Member
    2p

    Looks like the Word Is Not Installed error is back with some customers that installed Office 2013, then uninstalled it. If you bought a new computer since Office 2013 was released, you probably had to uninstall it to install Word 2010 (or earlier), so that would still apply to you.

    It looks like some versions of Office (mostly 2013) aren’t clearing their values in the registry when they uninstall.

    http://social.msdn.microsoft.com/Forums/en-US/vsto/thread/08f13e9d-895c-4102-b6d9-e327af8cf8c0/

    http://stackoverflow.com/questions/12957595/error-accessing-com-components

    In order to fix the issue, you would need to go into the registry and delete the unnecessary values.

    - Restart the computer.
    - Run regedit.exe
    - Find this key for 32-bit Windows and 32-bit Office or 64-bit Windows and 64-bit Office:
    HKEY_CLASSES_ROOTTypeLib{00020905-0000-0000-C000-000000000046}
    or this key for 64-bit Windows and 32-bit Office:
    HKEY_CLASSES_ROOTWow6432NodeTypeLib{00020905-0000-0000-C000-000000000046}
    - The following subkeys should be there for installed versions of Word:
    8.4 – if MS Word 2007 is installed
    8.5 – if MS Word 2010 is installed
    8.6 – if MS Word 2013 is installed
    - Remove the subkeys for *uninstalled* Word versions. For example if you have uninstalled Word 2013 then remove subkey “8.6?.
    The subkeys for installed Word versions only should be remain.
    - Launch Word, then close it.
    - Launch Doc-To-Help

    I attached an animated GIF (FindTypeLib.gif) that shows you how to do this. Your registry should look like mine (with just the 8.5 value in the subkeys) if you have Word 2010 installed.

    Attachments:
    1. FindTypeLib2

      FindTypeLib2.gif

    2. FindTypeLib5

      FindTypeLib5.gif

    #208648

    WayneKEMS
    Member

    Hello. We have some .pdf documents that we’re trying to include in some form or another into a Doc-to-Help Nethelp file. I know that the .pdf format isn’t supported for import into a Doc-to-Help project, but I was wondering if you had some ideas on a workaround. I’ve tried doing screen grabs and importing the .jpg files onto an .htm, but that doesn’t work since a folder is automatically created with the graphics, and I can’t bring that folder into the project (after I compile, I just get broken links on the blank page where the pictures should be). I’ve tried doing the same thing with .doc files, but when I import the .jpg files I can’t totally resize them to fill the page.

    (I should note that I’ve used Robohelp for years prior to Doc-To-Help, and with RH you can just import .pdfs as “baggage files” and link to them from .htm topics in the help project…Doc-To-Help has numerous other advantages, though. It would be nice if Doc-to-Help provided a similar “baggage file” capability.)

    Please let me know if you have any other ideas – we really could use the .pdf content that we have for our project. Thanks a lot.

    #208649

    Brad Keller
    Member
    2p

    Wayne,

    You should just be able to make a link to a file (either using the Hyperlink button on the Insert tab in Word or creating an External link in the built-in editor) on your computer.

    When you build your NetHelp target, any files you’ve linked to will get placed in the LinkedDocuments folder in your NetHelp folder. Wherever you place that folder, the LinkedDocuments folder will go with it, so your links should always work and shouldn’t dead end.

    Hope this helps!
    Brad

    #208650

    WayneKEMS
    Member

    Brad,

    I followed the steps and everything worked fine. Thanks a lot for your help!

    Wayne

    #239467

    ram jos
    Member

    When I try to Check Out a document I get this error “The team project on the server has been upgraded to a newer Doc-To-Help version. To continue working with the project you must either upgrade Doc-To-Help on your computer or open this project offline”.

    The doc-to-help version is the same and has not been changed. Any fix for this issue to check out a document?
    Thanks
    Ram

    #239486

    C1_GatimT
    Member
    22p

    HI,

    When you get this message, you must be getting the build number as well installed that is different on the server end as compared to the one installed on your end.

    I’d suggest you to check this explicitly if the version on both the machines is same or not. If not then make sure that d2h on both the machines have same version.

    You may refer to the link below for more info:

    http://helpcentral.componentone.com/nethelp/d2h2013/default.htm#!WordDocuments/upgradingateamauthoringproject.htm

    Also I’d request you to post this issue as a separate thread, as this forum thread is for general problems and their solutions.

    Thanks

    #239793

    slkammer
    Member

    Hi Brad,

    A quick question…I am new to D2H and have legacy Help projects set to the HTML target that include external PDFs (standard PDF and Adobe Presenter videos in PDF format).

    The links worked in D2H2012 as long as the files were in the Media folder, but links do not work in 2013.1.0.814 (a black X appears). Microsoft Word 2010

    Is anyone else reporting this?

    Thanks, I appreciate your help.
    Sandy

    #240054

    C1_GatimT
    Member
    22p

    HI,

    This is caused by the age of the combination of the HTML Compiler and IE10.

    I do not believe this can be fixed within Doc To Help.

    As a workaround, I would suggest you to host all of the PDF files externally, then do an explicit hyperlink to each of them, such as

    External

    Internal links to PDF files do not seem to be reliable, so I would use a static web address. Also, set the target to _blank, which opens the link in the default browser on the end users computer.

    Thanks & regards,
    ~Gatim

    Note-: Please always post new issues in a separate thread.

    #606917

    lori_bain
    Member

    I have a (Word) project loaded. When I click the Theme button or the drop-down arrow next to it, the Theme Designer window is launched, but then I get an endless loading spinner. After about 5 minutes, it times out and I get a message that states “Internal preview error: timeout.” This happens *every* single time and it’s frustrating. If I want to change themes, I have to choose a theme blindly, then rebuild my project and view the preview, then lather, rinse, repeat until I hit on a theme I want to use. VERY time consuming. Any ideas why the Theme Designer window keeps timing out? Thanks in advance.

    Attachments:
    1. 2014-05-21_11-02-04

      2014-05-21_11-02-04.jpg

Viewing 15 posts - 16 through 30 (of 36 total)

The forum ‘Doc-To-Help’ is closed to new topics and replies.